ATM Service Disruption

Incident Report for pavilionpayments

Resolved

This incident has been resolved.
Posted May 16, 2026 - 00:03 UTC

Monitoring

Our third-party partner has confirmed that a fix has been applied, and the issue is expected to be resolved. We will continue to monitor the situation closely.
Posted May 15, 2026 - 23:40 UTC

Identified

We are currently experiencing an ATM service disruption due to a third-party issue. We are actively monitoring the progress of this ongoing situation.
Posted May 15, 2026 - 23:29 UTC
This incident affected: ATM Services.