Echeck Transactions & Cash Advance [brick & mortar]

Incident Report for pavilionpayments

Resolved

This incident has been declared as resolved by F5. The F5 Distributed Cloud team has successfully completed all ongoing Regional Edge (RE) upgrades, including B-Ashburn DC12. The issue that caused the widespread 503 errors. Additional details are provided in the following link.

https://www.f5cloudstatus.com/incidents/zd0wr56wskmz
Posted Jul 07, 2025 - 04:39 UTC

Monitoring

The Incident has been escalated to F5. The F5 global incident response team is still working on a resolution. Pavilion will continue to monitor until F5 declares the incident fully resolved.

F5’s live status page is here: https://www.f5cloudstatus.com/incidents/zd0wr56wskmz.

Next update upon new available information.
Posted Jul 04, 2025 - 06:40 UTC

Identified

We’ve isolated the 503 errors to a global F5 cloud incident that is disrupting traffic across several points-of-presence and interface nodes; although Pavilion Payments’ platform remains healthy, the upstream outage is intermittently affecting customer connections. F5 is posting real-time updates here: https://www.f5cloudstatus.com/incidents/zd0wr56wskmz we’re monitoring their progress and will relay any material changes.
Posted Jul 04, 2025 - 06:13 UTC

Update

We are continuing to investigate this issue
Posted Jul 04, 2025 - 06:02 UTC

Investigating

We are currently investigating an issue.
Posted Jul 04, 2025 - 05:23 UTC
This incident affected: Player Cash Advance and Light-Speed Gateway.