ATM Service Disruption

Incident Report for pavilionpayments

Resolved

On Wednesday, May 20, 2026, Pavilion Payments experienced a P1 major incident causing ATM transaction failures and disconnects at multiple properties. The issue occurred during the implementation of a change by our service provider, NCR Atleos (CDS).

As of 8AM PST, NCR Atleos has since implemented stabilization measures, completed validation activities, and confirmed that the issue is fully resolved. All services are currently operating within expected parameters.
Posted May 20, 2026 - 17:15 UTC

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 10:01 UTC

Investigating

We are currently experiencing a disruption to ATM services and are actively investigating the issue.
Posted May 20, 2026 - 09:42 UTC
This incident affected: ATM Services.