Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2026 - 12:00 UTC
Scheduled
Our external cloud service provider Microsoft has scheduled maintenance on the Azure ExpressRoute infrastructure supporting our connectivity. Maintenance is expected to occur August 8, 2026, from 5:00 AM PT to 9:00 AM PT (12:00 UTC to 16:00 UTC).
Expected Impact: While ExpressRoute is designed to automatically fail over to a redundant connection during the maintenance window, there is a possibility of a brief interruption or temporary network degradation as traffic transitions between redundant paths. We will closely monitor services throughout the maintenance period and provide an update if the maintenance extends beyond the scheduled window or if any unexpected impact is observed.
Posted Aug 07, 2026 - 19:25 UTC
This scheduled maintenance affected: Pavilion Core Services, Player Cash Advance, and Light-Speed Gateway.